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Scope 
Welcome to the Legi for Windows 2.2 to Legitronic Labeling Software 3.6.2 Label Migration Guide. This 

guide provides an overview of the process, and explains how to perform the migration. This document is not 

intended to teach the reader how to use the software programs described in the process. Learning the 

software is the sole responsibility of the user.  

Introduction 
As of this writing it has been 10 years since the first 32 bit version of Legitronic was released. The last 

update to the 16 bit Legi for Windows 2.2.0 was Release 4, and was written to address Y2K issues. 

Hardware platforms, operating systems, and application software programs have changed many times in the 

decade between LegiWin 2 and the current version of Legitronic Labeling Software. As such, some of the 

technological chasms are too wide to cross. That being the case, it is well worth weighing the effort spent 

trying to bring your old labels forward into a new version of software against that of simply creating new 

labels. Either way, you will spend considerable time and effort on the project and you will still have to learn 

to use the new software.  

 

Legi for Windows 2 Series labeling software came in several versions from 2.0 to 2.2. These are 16 bit 

applications developed for Windows for 3.11 to 9X. While the latest version, 2.2, can be migrated directly 

into Legitronic Labeling Software 3.6, (a 32 bit application written for Windows XP Professional,) the 

earlier versions cannot. And again, a 2.2 label may not function in 3.6. 

 

Weber Marking Systems, Inc. Product Systems management reserves the right to determine whether or not a 

particular application is a good candidate for migration. 

 

This is a lengthy, very detailed and highly technical process and it is entirely possible that the label format 

file will be corrupted during this process or that the file will simply fail to migrate into the new software. 

This process cannot be performed quickly, or “walked through” over the phone. You will have to touch each 

label several times in both the old and the new software. You will need to be fluent in using MS Windows 

XP Professional, including some of the more advanced features such as setting up ODBC driver links and 

OLE DB driver links. You will need to have access to a Windows XP Professional login account with 

administrative permissions over the system you will be working with. You will also need to know how to 

work with MS Access or the database program you will be using.  

 

Additionally all versions of the Legi for Windows 2 Series software came with their own integrated Paradox 

database utility. The Paradox tables created with Legi for Windows 2.2 can be imported directly into MS 

Access 2003, while the Paradox tables created with Legi for Windows 2.1 and earlier cannot. The 2.1 

Paradox tables must be exported into and saved as a CSV file before they can be opened in MS Access 

2003. 

 

Be sure to back up all your files before beginning any of the processes outlined here.  



 

 

How This Guide Is Organized 

Section 1, Preparing the Legi for Windows 2.2 Labels 

Section 2, Migrating the 2.2 Databases into MS Access 2003 

Section 3, Installing Legitronic Labeling Software version 3.6 

Section 4, Opening the 2.2 Labels in Legitronic 3.6.2 

Appendix A, Migration Anomalies 

 
Conventions Used in This Guide 

 

Bold Italics Items, options, titles or locations on the computer 

[Bold in square brackets] Buttons to click on 

<Bold> in pointed brackets Computer keys 

“Italics in quotes” Things to type into the computer (without the quotes) 

Words > More words in Italics 

separated by greater-than sign 

Navigation through menus or paths 

  

 

Customer Support 
For Legitronic technical support, call 847-364-8500 (ext. 773) between the hours of 8:00 AM and 4:30 

PM, Monday through Friday. For hardware-related problems, call 847-364-8500 (ext. 776). There are 

also white papers covering the most frequently asked questions (FAQ) about Legitronic software on 

our web site. Just navigate an Internet browser to: www.webermarking.com/software_faqs.html. The 

CD that your software came on contains a User’s Manual. 
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1. Preparing the Legi for Windows 2.2 Labels 
 

In this section you will open each of your Legi for Windows 2.2 labels in Legi for Windows 2.2. You 

are looking for how the label has been designed to work, as well as to note certain label attributes such 

as Tracking Serial Numbers (TSN), database table names and contents, paragraph formatting and 

graphic file locations. After you gather the information you need, and make any necessary changes, 

you will save the label in Legi for Windows 2.2. 

 

1.1. Make backup copies of all your labels and databases. 

 

1.2. Open Legi for Windows 2.2 and log in as you normally do. 

 

1.3. Click [Label Design]. (Figure 1-1a, b) 

 

Figure 1-1a,                                                        Figure 1-1 b 

 

1.4. Click File > Open. (Figure 1-2) 

 

Figure 1-2 



 

Page 5 of 53 

1.5. Navigate to the location of your labels. (Figure 1-3 Arrows 1 and 2) 

 

1.6. Choose your first label. (Figure 1-3 Arrow 3) 

 

1.7. Click [OK]. (Figure 1-3 Arrow 4) 

 

Figure 1-3 

 

1.8. Figure 1-4 shows the label that you opened. 

 

Figure 1-4 
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1.9. Double click on a blank area of the label to open the Label Settings dialog box. (Figure 1-5) 

 

1.10. Take note of the values that are in the options called out by Figure 1-5 Arrows 1 through 5. You 

will need to know this information later. 

 

1.11. Click [Options]. (Figure 1-5 Arrow 6) 

 

Figure 1-5 

 

1.12. Click [Printer Options].  (Figure 1-6) 

 

Figure 1-6 
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1.13. Uncheck any choices selected in Label Preview at Print Time. (Figure 1-7) 

 

1.14. Click [OK]. (Figure 1-7) 

 

Figure 1-7 

 

1.15. Take note of the values that are in the options called out in Figure 1-8 Arrows 1-3. Your will 

need to know this information later. 

 

1.16. Click [OK]. (Figure 1-8 Arrow 4) 

 

Figure 1-8 
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1.17. Click [OK]. (Figure 1-9) You are brought back to your label design. 

 

Figure 1-9 

 

1.18. Click and drag your cursor from the upper left corner of the label to the lower right corner and 

then release the mouse button. All the fields on the label will be selected (enclosed in thin-lined 

boxes) and a large box will enclose them all. (Figure 1-10) 

 

Figure 1-10 

 

1.18.1. Look carefully at the fields in Figure 1-10. Notice how the yellow field and the blue field 

overlap in the green area. This is a problem that needs to be corrected. You will need to 

correct this problem wherever you find it. 
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1.18.2. Click outside the box, and all the fields will be deselected. (Figure 1-11) 

 

Figure 1-11 

 

1.18.3. Click on the TR. That field will be selected. (Figure 1-12) 

 

Figure 1-12 

 

1.18.4. Hover your cursor over a corner of the selection box. Note how the cursor changes from a 

cross-hair to a double arrow. (Figure 1-13) 

Figure 1-13 
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1.18.5. Click and drag the cursor while it’s a double arrow to resize the field. (Figure 1-14) 

 

Figure 1-14 

 

1.18.6. Click off of the field to deselect it. (Figure 1-15) 

 

Figure 1-15 

 

1.18.7. Click and drag your cursor from the upper left corner of the label to the lower right corner 

and then release the mouse button. All the fields on the label will be selected (enclosed in 

thin-lined boxes) and a large box will enclose them all. Note that the yellow and blue fields 

are no longer overlapping. (Figure 1-16) 

 

Figure 1-16 
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1.19. Click outside the box, and all the fields will be deselected. (Figure 1-17) 

 

Figure 1-17 

 

1.20. Double-click on the TR. (Figure 1-18a) That will open the field properties dialog box. (Figure 1-

18b) 

 

Figure 1-18a                                                                   Figure 1-18b 

 

1.20.1. Note that the Field Name in Figure 1-18b is 0002. There is nothing wrong with this kind 

of name as long as you remember which field is which. We recommend that you give fields 

meaningful names. This will help you in the long run. 

 

1.20.2. Look at the two options called out by Figure 1-18b Arrow 1. There are three valid choices 

for migration. They are: 

• Neither option checked 

• Only Auto Wrap checked 

• Only Dynamic fit checked 

 

NOTE: If both Auto Wrap AND Dynamic fit are checked, UNCHECK Dynamic fit. 

 

1.20.3. Look at the two options called out by Figure 1-18b Arrow 2. The option checked at Arrow 

2 will determine what the button called out by Arrow 3 does.  

 

1.21. Click the button called out by Figure 1-18b Arrow 3. 



 

Page 12 of 53 

1.22. Look at the options called out by Figure 1-19 Arrow 1. These are the types of expressions that 

can be used to create a field.  

 

1.23. Make a note of what expression type the field is 
*
.(Figure 1-19)   

 

*
In our example, Field 0002 is a Constant expression. Constant means that the data is 

always the same, or constant. When chosen, Legitronic opens a Constant Data box, called 

out by Figure 1-19 Arrow 2, which contains the data for the field. 

 

Figure 1-19 

 

Here are examples of the other Expression Types 

 

 

Here is a Reference Field. A Reference Field 

displays the data contained in the field it 

references. In this case Field 0002 references 

Field 0007. 
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Here is a Database Field. A Database Field 

gets its data from a particular field in a 

database record, based on some 

predetermined criteria. In this example, Field 

0002 will go to the table called out in 

Database Table and get whatever is called 

for in the Return Field based on the record 

that corresponds to the data contained in 

Field 0007. 

 

 

 

 

 

 

Here is a Text File Field. A Text File Field 

displays the contents of the text file called 

out in the Text File field. 

 

NOTE: Since the inception of the Unicode 

Character Set, Text File fields are best 

handled within the confines of a database 

record. This is one situation where recreating 

your labels from scratch is advisable. You 

will spend more time and effort trying to 

convert one of these fields than it would take 

to make a new label. 

 

 

 

Here is a Time or Date Field. A Time or 

Date Field displays the computer’s time or 

date in various formats. 
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Lastly, here is a String Builder Field. This type of 

expression utilizes strings of Legitronic programming 

data expression commands and variables. Some of the 

expressions have changed in the decades since Legi for 

Windows 2.2 was released. If you are not familiar with 

these commands, leave this alone. Legitronic Support 

can help you to troubleshoot problems that might occur 

after the migration to Legitronic Labeling Software 3.6. 

 

 

 

 

 

 

 

 

1.24. Now, we go back to our Field Properties, > Expression dialog box. (Figure 1-20) 

 

Figure 1-20 

 

1.25. See if the field contains a Serial Number option as called out by Figure 1-20 Arrow 3. If it does, 

be sure to note all the related settings. 

 

1.26. Click [OK]. (Figure 1-20 Arrow 4) 
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1.27. Double-click on the field to the right of Field 0002. (Figure 1-21a) This opens the properties 

dialog box for Field 0007. (Figure 1-21b) 

 

Figure 1-21a      Figure 1-21b 

 

1.28. Check the status of the Auto Wrap, Dynamic fit check boxes for valid configurations, (Figure 1-

21b Arrow 1). 

 

1.29. Note that on this field, the Supplied Data option is chosen, (Arrow 2). This in turn caused the 

button called out by Figure 1-12b Arrow 3 to read, Supplied… 

 

1.30. Click [Supplied…] (Figure 1-12b Arrow 3). This opens the Supplied dialog box. 

 

Figure 1-22 

 

1.31. Note that the Data Source specified is Keyboard. (Figure 1-22 Arrow 1) 

 

1.32. Note that the Supplied Entry Time specified is Print Labels. (Figure 1-22 Arrow 2) 
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1.33. Note that the Operator Prompt, (Figure 1-23 Arrow 3) and the Default Data (Figure 1-23 

Arrow 4) fields are blank, but could and indeed usually do, contain data. 

 

1.33.1. Let’s look at some of the other options on this feature. (Figure 1-23) 

 

Figure 1-23 

 

1.33.1.1. If Remote Input (Arrow A) is checked the options called out by Arrow B would be 

active and one or more would be checked. 

 

1.33.1.2. If Table Lookup (Arrow a) is checked there would be entries in the fields called out 

by Arrows b, c and d. You would need to take note of this information. 

 

1.34. Click [OK] until you get back to your label design. 

 

1.35. Repeat all of the steps outlined in this section for every field on every label. 
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2. Migrating the 2.X Databases into MS Access 2003 
 

2.1. Finding the database references 

 

2.1.1. Log into Windows using an account with administrative privileges. 

 

2.1.2. Log into Legi for Windows and open the first label in Design mode. 

 

2.1.3. Look for any fields on the labels that access a database. These can be fields that use 

Supplied Data (Figure 2-1a) with a Table Lookup (Figure 2-1b), a Tracking Serial Number 

(Figure 2-1c), or a field with an expression type of Database. (Figure 2-1d) 

 

Figure 2-1a      Figure 2-1b 

Figure 2-1c      Figure 2-1d 

 

2.1.4. Write down the name of any databases or tables and their locations 

NOTE: The Tracking Serial Number Database is different and we’ll deal with that separately. 

 

2.1.5. Repeat steps 2.1.3 and 2.1.4 until all labels have been examined. 
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2.1.6. Exit Legi for Windows. 

 

2.2. Creating the MS Access database 
 

2.2.1. Open MS Access 2003. 

 

2.2.2. Click File > New. (Figure 2-2a, b) 

 

Figure 2-2a       Figure 2-2b 

 

2.2.3. Choose Blank Database from the New File list. (Figure 2-3) 

 

Figure 2-3 

 

2.2.4. Browse to the location were you will keep your new database. 
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2.2.5. Change the default database name to a meaningful name (e.g. “LabelData”) in the File New 

Database dialog box, (Figure 2-4a) and click [Create]. (Figure 2-4b)  

 

Figure 2-4a       Figure 2-4b 

 

 

2.3. Importing the contents of the old databases 

 

2.3.1. Click File > Get External Data > Import when the Tables screen opens. (Figure 2-5a, b) 

 

Figure 2-5a       Figure 2-5b 
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2.3.2. Browse to the location of your existing databases and choose the Paradox (*.db) option in 

the File of type box. (Figure 2-6) 

 

Figure 2-6 

 

2.3.3. Highlight the database you want to import and click [Import]. (Figure 2-7a) You will see 

the Paradox database imported into your MS Access 2003 database as a table. (Figure 2-7b) 

 

Figure 2-7a       Figure 2-7b 

 

2.3.4. Repeat Steps 2.3.2 through 2.3.3 until all databases are imported 
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2.4. Configuring the new database 
 

2.4.1. Right click on the first table you imported in Steps 2.3.2 through 2.3.4 , (Figure 2-8a) and 

choose Design View from the menu. (Figure 2-8b) 

 

Figure 2-8a       Figure 2-8b 

 

2.4.2. Change the Data Types to Text for all fields in the table. (Figure 2-9) 

 

Figure 2-9 

 

2.4.3. Click [Save] and close the table. 

 

2.4.4. Repeat the previous step until all fields in all tables are set to Text and have been saved. 

 

NOTE:  If you use the Tracking Serial Number feature, you need to perform Steps 2.3.2 and 2.3.3 again, 

but in this case the Legi for Windows database table is named tkserial.db, and is located in the C:\LEGI 

FOR WINDOWS\DATA folder. You should not have to edit the design of this table at all. 
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2.5. Configuring the ODBC driver and defining a Data Source 
 

2.5.1. Click Start > Control Panel > Administrative Tools > Data Sources (ODBC). (Figure 2-10) 

 

Figure 2-10 

 

2.5.2. Select the System DSN tab and click [Add] (Figure 2-11) 

 

Figure 2-11 
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2.5.3. Select Microsoft Access Driver and click [Finish]. (Figure 2-12) 

 

Figure 2-12 

 

2.5.4. Enter a Data Source Name. (Figure 2-13) A Data Source Name (DSN) is the name that 

Legitronic uses to connect to your database.  

Note: The description field is optional.  

 

2.5.5. Click [Select]. (Figure 2-13) 

 

 
Figure 2-13 
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2.5.6. Select the MS Access database you created and named LabelData. (Figure 2-14) 

 

2.5.7. Click [OK]. (Figure 2-14) 

 

Figure 2-14 

 

2.5.8. Click [OK].(Figure 2-15) 

 

 
Figure 2-15 
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2.5.9. You should now be back at the ODBC Data Source Administrator screen. (Figure 2-16). 

Click [OK]. 

 

 
Figure 2-16 
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3. Installing Legitronic Labeling Software version 3.6 

 

What You Will Need 

• Windows XP Professional - Home editions are not supported 

• A license key (dongle) 

• Administrative privileges over the PC on which you’re installing Legi 

• A database (MS Access, SQL, etc) that uses current database linking tools, I.E. ODBC, OLE DB, 

Microsoft Jet, ect 
*
 

*
Only if your formats require database interaction 

 

3.1. Install the Legitronic Labeling Software 

 

3.1.1. Log into Windows using an account with administrative privileges. 

 

3.1.2. Place the Legitronic Labeling Software CD in the CD ROM drive and let it start. Choose the 

option to install as a Single User Hardware Key. (Figure 3-1) 

 

Figure 3-1 
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3.1.3. After Legitronic is installed, go to the Windows Program Group that the installation created 

and run the Sentinel Installer program. (Figure 3-2a-b) 

 

Figure 3-2a      Figure 3-2b 

 

3.2. Install New Printer Drivers 

 
3.2.1. Log into Windows using an account with administrative privileges. 

 

3.2.2. Open the Printers and Faxes area of Windows. (Figure 3-3) 

 

3.2.3. Click the Add a Printer link. (Figure 3-3) 

 

Figure 3-3 
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3.2.4. Follow the Add a Printer Wizard instructions. (Figure 3-4) 

 

Figure 3-4 

 

3.2.5. Choose the Local Printer option, but UNCHECK Automatically detect and install my 

Plug and Play printer. (Figure 3-5) 

 

Figure 3-5 
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3.2.6. Direct the printer to the port where it is installed. (Figure 3-6) 

NOTE: If using a networked printer contact your Network Administrator. 

Figure 3-6 

 

3.2.7. Click [Have Disk] when the list of manufacturers and printers on the Install Printer 

Software window comes up. (Figure 3-7) 

 

Figure 3-7 



 

Page 30 of 53 

3.2.8. Click [Browse] on the Install from Disk window. (Figure 3-8) 

 

Figure 3-8 

 

3.2.9. Browse to the C:\Program Files\Weber Marking Systems\Legitronic Labeling 

Software\Printer Drivers\Windows-NT-2000-XP\English folder. (Figure 3-9) 

 

Figure 3-9 
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3.2.10. Double-click on the WeberNT file. (Figure 3-10) 

 

Figure 3-10 

 

3.2.11. Click [OK] on the Install from Disk window. (Figure 3-11) 

 

Figure 3-11 
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3.2.12. Scroll through the list of printers and highlight the model to install. (Figure 3-12) 

 

3.2.13. Click [Next]. (Figure 3-12) 

NOTE: If asked to replace or keep the existing driver, choose replace. 

 

Figure 3-12 

 

3.2.14. Continue through the Add a Printer Wizard. 

 

3.2.15. Choose No to Default Printer, Share Printer and Print a Test Page. (Figure 3-13a, b, c) 

 

Figure 3-13a   Figure 3-13b   Figure 3-13c 
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3.2.16. Click [Finish] to complete the Add Printer Wizard. (Figure 3-14) 

 

Figure 3-14 

 

3.2.17. Click [Continue Anyway] to the Windows Logo Testing warning.(Figure 3-15) 

 

Figure 3-15 
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3.3. Configuring the printer driver 
 

3.3.1. Right-click on the newly installed printer. (Figure 3-16) 

 

3.3.2. Choose Properties from the quick-pick menu. (Figure 3-16) 

 

Figure 3-16 

 

3.3.3. Click on the Ports tab. (Figure 3-17) 

 

Figure 3-17 
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3.3.4. Uncheck the Enable Bidirectional Support option (near the lower left). (Figure 3-18) 

 

Figure 3-18 

 

NOTE: If you need to make changes to your port settings click [Configure Port]. (Figure 3-19a, b) Ask 

your IS department if such changes are needed. (The recommended COM1 settings are shown) 

 

Figure 3-19a       Figure 3-19b 
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3.3.5. Click on the Device Settings tab. (Figure 3-20) 

 

Figure 3-20 

 

3.3.6. Click [Properties] on the Setup Label Size option. (Figure 3-21) 

 

Figure 3-21 
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3.3.7. Change the label settings from the default values to something larger than your largest label, 

(Figure 22a, b) and click ]OK]. 

NOTE: If your largest label’s size is less than or equal to the default values, skip this step. 

Figure 3-22a       Figure 3-22b 

 

3.3.8. Click [Close] to finish setting up your printer. (Figure 3-23) 

 

Figure 23 

 

Your Legitronic Labeling Software is installed and ready to use. 
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4. Opening the Legitronic for Windows 2.2 Labels in Legitronic 
Labeling Software version 3.6 

 

4.1. Start the Legitronic Labeling Software.  

 

4.1.1. Click Start > All Programs >Weber Marking Systems > Legitronic Labeling Software > 

Legitronic Labeling Software) (Figure 4-1) 

 

Figure 4-1 

 

4.1.2. Key in the Login Name “weber” and Login Password “legi” and click [OK]. 

 

Tracking Serial Numbers  
 

Tracking Serial Numbers are serial numbers that are given a name and tracked by Legitronic. When a 

label includes a tracking serial number field, the initial value of that field is obtained from the Tracking 

Serial Number table of your database from Section 2. When the label print job is submitted, the next serial 

number to be used is stored in the Tracking Serial Number table. 

 

When a label includes a regular serial number field, Legi does not keep track of the next serial number to 

be used. Each time the label is printed, the serial number begins at the specified start point. 
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4.2. Configuring Legitronic for Serial Number Tracking 
 

4.2.1. Click File > Configuration. The Configuration dialog box opens. (Figure 4-2) 

 

Figure 4-2 

 

4.2.2. Click the System Tables tab. (Figure 4-3) 

 

4.2.3. Select Tracking Serial Number from the Table Type drop-down list. (Figure 4-3) 

 

Figure 4-3 
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4.2.4. Click [Database Providers] to setup a connection to the Tracking Serial Number Database. 

(Figure 4-4) 

 

Figure 4-4 

 

4.2.5. Choose Microsoft OLE DB Provider for ODBC Drivers from the list on the Provider tab, 

then click [Next >>]. (Figure 4-5) 

 

Figure 4-5 
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4.2.6. Use the data source name you created in step 2.22. (Figure 4-6a) 

 

4.2.7. Click [Test Connection] and then [OK]. (Figure 4-6b) 

 

Figure 4-6a      Figure 4-6b 

 

4.2.8. Click [OK]. (Figure 4-7) 

 

Figure 4-7 
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4.2.9. Select tkserial, (Figure 4.8a) and then click [OK]. (Figure 4-8b) 

 

Figure 4-8a      Figure 4-8b 

 

4.3. Opening the Label 

 

4.3.1. Click File > Open Label for Design. (Figure 4-9) 

 

Figure 4-9 
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4.3.2. Browse to and highlight the label you want to import and click [Open]. (Figure 4-10a, b) 

 

Figure 4-10a      Figure 4-10b 

 

4.3.3. Click [OK] when the message You are opening a Legitronic Labeling Software for 

Windows 2.2.0 label format. If you save it, it will be upgraded to 3.6.X appears. (Figure 4-

11) 

 

Figure 4-11 
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4.3.4. If the printer that the label format is using is not found, you will see the following: (Figure 

4-12) 

 

Figure 4-12 

 

4.3.5. Pull down the printer list and select your printer. (Figure 4-13)  

NOTE: If your printer is not listed, review the Installing a Printer section of this document. 

 

Figure 4-13 
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4.3.6. If your label is using a database, you will see the following: (Figure 4-14) 

 

Figure 4-14 

 

4.3.7. Enter the DSN from Step 2.22 exactly as you entered it in Step 2.22 and click [OK]. (Figure 

4-15) 

 

Figure 4-15 
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4.3.8. Click the Save Icon when the label opens. (Figure 4-16)  

 

Your label is now in 3.6 format. Review each field on each label and make any adjustments needed for 

them all to look and function as intended, then save the label. 

 

Figure 4-16 
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4.4. Using Tracking Serial Numbers in Label Formats 
 

4.4.1. Right-click a field on the label and select Serial from the quick-pick men. Figure 4-17a) The 

Field Properties dialog box opens with the Serial Numbers tab activated. (Figure 4-17b) 

 

Figure 4-17a        Figure 4-17b 

 

4.4.2. In the Serial Number section, click Tracking. 

 

4.4.3. From the Tracking Serial Number Name drop-down list, select the appropriate serial 

number. 

 

4.4.4. Click [OK]. 
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5. Appendix A, Migration Anomalies 
 

When you are working with technologies that have such a long span of time between their respective 

inceptions, you can expect that not everything will go smoothly. This is just the nature of technology. 

This section will address two situations that you may encounter. 

 

5.1. Labels that will not open in Legitronic 3.6 

 

5.1.1. Only labels created in Legi for Windows 2.2.0 are able to be opened in Legitronic 3.6. You 

may encounter labels that were created in earlier versions that ran fine in 2.2.0, but won’t 

open in 3.6. When these older labels were run in 2.2.0, they simply ran, they did not 

“become” 2.2.0 formats. If you try to open one of these, Legitronic will tell you that it cannot 

open them due to their version. There is nothing you can do to circumvent this. These labels 

will have to be redesigned. 

 

5.2. Paradox databases that will not open in MS Access 

 

5.2.1. Older version of Legi for Windows used older versions of Paradox to manage the databases. 

These older version may not be recognized by current versions of MS Access. As in the 

above scenario, trying to open and save the tables in 2.2.0 will not change anything. You will 

need to go through an entirely different process. 

 

5.2.2. Open Legitronic for Windows 2.2 and click [Database]. (Figure 5-1) 

Figure 5-1 
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5.2.3. Click [Open]. (Figure 5-2) 

 

Figure 5-2 

 

5.2.4. Browse to C:\legiwin\database. (Figure 5-3) 

 

5.2.5. Note that the List Files of Type is set to Database tables(*.db). (Figure 5-3) 

 

5.2.6. Highlight the table you want and click [OK]. (Figure 5-3) 

 

Figure 5-3 
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5.2.7. Note the field names. You’ll need these later. (Figure 5-4) 

 

5.2.8. Click [Export]. (Figure 5-4) 

 

Figure 5-4 

 

5.2.9. Click [Choose Destination]. (Figure 5-5) 

 

Figure 5-5 
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5.2.10. Browse to C:\legiwin\database. (Figure 5-6) 

 

5.2.11. Note that the List Files of Type is set to ASCII files(*.csv). (Figure 5-6) 

 

5.2.12. Give the table the same name as the original name. (Figure 5-6) 

 

5.2.13. Click [OK]. (Figure 5-6) 

 

Figure 5-6 

 

5.2.14. Click [OK]. (Figure 5-7) 

 

Figure 5-7 
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5.2.15. Open the MS Access database you created earlier in this process and prepare to import the 

table as before. 

 

5.2.16. Change Files of Type to Text Files (*.txt, *.csv, *.tab, *.asc). (Figure 5-8) 

 

5.2.17. Click [Import].(Figure 5-8) 

 

Figure 5-8 

 

5.2.18. Choose the Delimited option, and then click [Next]. (Figure 5-9a) 

 

5.2.19. Choose Comma as the delimiter, and then click [Finish]. (Figure 5-9b) 

 

Figure 5-9a        Figure 5-9b 
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5.2.20. Open the table and go into design view as you did in the tables you already imported. 

(Figure 5-10a) 

 

5.2.21. Change the Field Names to match those in the original table, and change their DataTypes 

to Text. (Figure 5-10b) 

 

5.2.22. Click [Save] and exit the table. (Figure 5-10b) 

 

Figure 5-10a        Figure 5-10b 

 

 

 


